+ All Categories

1

Date post: 22-Oct-2014
Category:
Upload: ifeakor-young-kosisochukwu
View: 240 times
Download: 1 times
Share this document with a friend
Popular Tags:
31
CHAPTER 1 1. INTRODUCTION The purpose of this document is to provide an MSc case study Report for the module CTP141N (Advance Routing Protocol) of MSc course in Network Management and Security taught by London Metropolitan University. This document contains the design and implementation of two network scenarios for an international travel agency. 1.1 Scenario 1 Plan, design and implement complex EIGRP based Network for ITA. Establish network connectivity between International Travel Agency (ITA) core network which is set up with EIGRP and a Local Travel agency (LTA) network which was running OSPF which ITA recently acquired. 1.2 Scenario 2 Plan, design and implement a complex BGP/OSPF based network for International Travel Agency. Because International Travel Agency relies heavily on the internet for its advertising and sales, they need a redundant route to the internet, a backup route to avoid a single point of failure to the internet.
Transcript
Page 1: 1

CHAPTER 1

1. INTRODUCTION

The purpose of this document is to provide an MSc case study Report for the module CTP141N (Advance Routing Protocol) of MSc course in Network Management and Security taught by London Metropolitan University.

This document contains the design and implementation of two network scenarios for an international travel agency.

1.1 Scenario 1

Plan, design and implement complex EIGRP based Network for ITA.

Establish network connectivity between International Travel Agency (ITA) core network which is set up with EIGRP and a Local Travel agency (LTA) network which was running OSPF which ITA recently acquired.

1.2 Scenario 2

Plan, design and implement a complex BGP/OSPF based network for International Travel Agency.

Because International Travel Agency relies heavily on the internet for its advertising and sales, they need a redundant route to the internet, a backup route to avoid a single point of failure to the internet.

Page 2: 1

CHAPTER2

2.1 SUMMARY OF COMPANY Scenario 1

Company Name: International Travel Agency (ITA)

Acquired company name: Local Travel Agency (LTA)

2.1 NETWORK REQUIRMENT

* International Travel Agency (ITA) needs its core network to run EIGRP in AS 1.

* ITA core network is made up of three routers R1, R2, R3 and an Ethernet switch SW1

* summarize the loopback interfaces on R2 with the best possible summary to the other EIGRP routers

* Local Travel Agency (LTA) Router R4 needs to communicate with ITA core via OSPF area 0

* Redistribute OSPF into EIGRP

* originate a default router into OSPF process from R3

2.2 OBJECTIVE

Plan, design and implement the complex International Travel Agency (ITA) EIGRP network based on the above stated specifications,

Verify that all configurations are operational and functioning according to the guideline stated above

Page 3: 1

2.4 SETTING UP THE PHYSICAL LAYOUT OF THE NETWORK

SCENARIO 1: EIGRP/OSPF TOPOLOGY DIAGRAM

Fig 1

Page 4: 1

SCENARIO 1: IP Address table

DEVICE INTERFACE IP ADRESS SUBNET MASK DEFAULT GATEWAY

R1 S0/0 192.168.1.129 255.255.255.252 N/A

S0/1 192.168.1.133 255.255.255.252 N/A

LOOPBACK1 192.168.1.1 255.255.255.252 N/A

R2 S0/0 192.168.1.130 255.255.255.252 N/A

Fa0/0 192.168.1.161 255.255.255.224 N/A

Loopback101 192.168.1.101 255.255.255.252 N/A

Loopback105 192.168.1.105 255.255.255.252 N/A

Loopback109 192.168.1.109 255.255.255.252 N/A

Loopback113 192.168.1.113 255.255.255.252 N/A

R3 S0/0 192.168.1.134 255.255.255.252 N/A

S0/1 10.1.1.3 255.255.255.248 N/A

Fa0/0 192.168.1.162 255.255.255.224 N/A

Loopback5 192.168.1.5 255.255.255.252 N/A

Loopback192 192.168.100.1 255.255.255.0 N/A

R4 S0/0/0 10.1.1.4 255.255.255.248 N/A

Loopback 4 10.4.4.4 255.255.255.0 N/A

SW1 Fa0/3 VLAN 1 255.255.255.224 N/A

Fa0/5 VLAN1 255.255.255.224 N/AHJ

FIG: 2

Page 5: 1

SCENARIO 1: DEVICE LINK TABLE

FROM DEVICE

INTERFACE TO DEVICE INTERFACE LAYER 1 & 2 FEATURE & PROTOCOLS

R1 S0/0 R2 S0/0 HDLC

S0/1 R3 S0/0 HDLC

R2 S0/0 R1 S0/0 HDLC

Fa0/0 SW1 Fa0/3 ETHERNET

R3 S0/0 R1 S0/1 HDLC

S0/1 R4 S0/0 HDLC

Fa0/0 SW1 Fa0/5 ETHERNET

SW1 Fa0/3 R2 Fa0/0 ETHERNET

Fa0/5 R3 Fa0/0 ETHERNET

R4 S0/0 R3 S0/1 HDLC

Fig; 3

Page 6: 1

CHAPTER 3

3.1 CONFIGURATIONS

The ITA core network is running EIGRP in AS 1.Router R1 ConfigurationTo rename router name from router to R1Router(config)#hostname R1To configure Loopback addressR1(config)#interface loopback 1R1(config-if)#ip address 192.168.1.1 255.255.255.252R1(config-if)#no shutdownR1(config-if)#exitTo configure Interface S0/0R1(config)# int s0/0R1(config-if)#ip address 192.168.1.129 255.255.255.252R1(config-if)#clock rate 64000R1(config-if)#no shutdownR1(config-if)#exitTo configure interface s0/1R1(config-if)#interface s0/1R1(config-if)#ip address 192.168.1.133 255.255.255.252R1(config-if)#no shutdownR1(config-if)#To Configure EIGRP on this routerR1(config)#router eigrp 1R1(config-router)#network 192.168.1.1R1(config-router)#network 192.168.1.129R1(config-router)#network 192.168.1.133R1(config-router)#no auto-summaryR1(config-router)#exit

Router R2 ConfigurationTo rename router name from router to R2Router(config)#hostname R2To configure Loopback addressR2(config)#interface loopback 101R2(config-if)#ip add 192.168.1.101 255.255.255.252R2(config-if)#no shutdownR2(config-if)#interface loopback 105R2(config-if)#ip add 192.168.1.105 255.255.255.252R2(config-if)#no shutdownR2(config-if)#interface loopback 109R2(config-if)#ip add 192.168.1.109 255.255.255.252R2(config-if)#no shutdownR2(config-if)#interface loopback 113R2(config-if)#ip add 192.168.1.113 255.255.255.252R2(config-if)#no shutdown

Page 7: 1

R2(config-if)#

To configure Interface S0/0R2(config-if)#interface s0/0R2(config-if)#ip address 192.168.1.130 255.255.255.252R2(config-if)#no shutdownR2(config-if)#exitTo configure Interface f0/0R2(config)#interface f0/0R2(config-if)#ip address 192.168.1.161 255.255.255.224R2(config-if)#no shutR2(config-if)#To Configure EIGRP on this routerR2(config)#router eigrp 1R2(config-router)#network 192.168.1.101 R2(config-router)#network 192.168.1.105 R2(config-router)#network 192.168.1.109 R2(config-router)#network 192.168.1.113 R2(config-router)#network 192.168.1.130R2(config-router)#network 192.168.1.161R2(config-router)#no auto-summaryR2(config-router)#end

Router R3 ConfigurationTo rename router name from router to R3Router(config)#hostname R3To configure Loopback addressR3(config)#interface loopback 5R3(config-if)#ip address 192.168.1.5 255.255.255.252R3(config-if)#interface loopback 192R3(config-if)#ip address 192.168.100.1 255.255.255.252R3(config-if)#exitR3(config-if)#To configure Interface S0/0R3(config)#interface s0/0R3(config-if)#ip address 192.168.1.134 255.255.255.252R3(config-if)#clock rate 64000R3(config-if)#no shutdownR3(config-if)#exitTo configure Interface f0/0R3(config)#interface f0/0R3(config-if)#ip address 192.168.1.162 255.255.255.224R3(config-if)#no shutdownR3(config-if)#exitTo configure Interface S0/1R3(config)#interface s0/1R3(config-if)#ip address 10.1.1.3 255.255.255.248R3(config-if)#clock rate 64000R3(config-if)#no shutdownR3(config-if)#exit

Page 8: 1

To Configure EIGRP on this routerR3(config)#router eigrp 1R3(config-router)#network 192.168.1.162R3(config-router)#network 192.168.1.134R3(config-router)#network 192.168.1.5 R3(config-router)# no auto-summary R3(config-router)#exitR3(config)#exitR3#

Summarize the loopback interfaces on R2 with the best possiblesummary to the other EIGRP routers

Summarize the loopback interfaces on R2R2(config)#interface s0/0R2(config-if)#ip summary-address eigrp 1 192.168.1.101 255.255.255.240 R2(config-if)#*Mar 1 00:14:21.691: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 192.168.1.129(Serial0/0) is down: summary configuredR2(config-if)#*Mar 1 00:14:24.399: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 192.168.1.129(Serial0/0) is up: new adjacencyR2(config-if)#exitR2(config)#interface f0/0R2(config-if)#ip summary-address eigrp 1 192.168.1.101 255.255.255.240 R2(config-if)#exit

Show IP route on router R1Before Summarize the loopback interfaces on R2R1#sh ip routeCodes: C - connected, S - static, R - RIP, M - mobile, B - BGPD - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter areaN1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2E1 - OSPF external type 1, E2 - OSPF external type 2i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2ia - IS-IS inter area, * - candidate default, U - per-user static routeo - ODR, P - periodic downloaded static routeGateway of last resort is not set192.168.1.0/24 is variably subnetted, 7 subnets, 2 masksD 192.168.1.104/30 [90/2297856] via 192.168.1.130, 00:01:13, Serial0/0D 192.168.1.108/30 [90/2297856] via 192.168.1.130, 00:01:13, Serial0/0D 192.168.1.100/30 [90/2297856] via 192.168.1.130, 00:01:13, Serial0/0D 192.168.1.112/30 [90/2297856] via 192.168.1.130, 00:01:13, Serial0/0C 192.168.1.0/30 is directly connected, Loopback1D 192.168.1.160/27 [90/2172416] via 192.168.1.130, 00:01:13, Serial0/0

Page 9: 1

C 192.168.1.128/30 is directly connected, Serial0/0

After Summarize the loopback interfaces on R2R1#sh ip routeCodes: C - connected, S - static, R - RIP, M - mobile, B - BGPD - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter areaN1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2E1 - OSPF external type 1, E2 - OSPF external type 2i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2ia - IS-IS inter area, * - candidate default, U - per-user static route

o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

192.168.1.0/24 is variably subnetted, 5 subnets, 3 masks

D 192.168.1.96/28 [90/2297856] via 192.168.1.130, 00:01:05, Serial0/0

D 192.168.1.112/30 [90/2297856] via 192.168.1.130, 00:01:05, Serial0/0

C 192.168.1.0/30 is directly connected, Loopback1

D 192.168.1.160/27 [90/2172416] via 192.168.1.130, 00:01:05, Serial0/0

C 192.168.1.128/30 is directly connected, Serial0/0

R1#

Loopback 192 on R3 represents a connection to the Internet. Originate a default route into EIGRP from R3.

Injecting a Default Route into EIGRP: IP Default Network

R3(config)#router eigrp 1

R3(config-router)#network 192.168.100.1

R3(config-router)# no auto-summary

R3(config-router)#exit

Creates a static default route to send all traffic with a destination network not in the routing table to the exit interface

R3(config)#ip route 0.0.0.0 0.0.0.0 loopback 192

Define 192.168.100.0 network as a candidate default route.

R3(config)#ip default-network 192.168.100.0

R3(config)#exit

Page 10: 1

Router R4 configurationsTo configure Interface S0/0R4(config)#int s0/0R1(config-if)#ip address 10.1.1.4 255.255.255.248R1(config-if)#no shutdownR1(config-if)#exitTo configure Loopback addressR4(config)#interface loopback 4R4(config-if)#ip address 10.4.4.4 255.255.255.0R4(config-if)#exitTo Configure OSPF on R4R4(config)#router ospf 1R4(config-router)#network 10.1.1.4 255.255.255.248 area 0R4(config-router)#network 10.4.4.4 255.255.255.0 area 0R4(config)#exit

To Configure OSPF on R3 R3(config)#router ospf 1R3(config-router)#network 10.1.1.3 255.255.255.248 area 0R3(config-router)#exitR3(config)#exit

Redistribute OSPF into EIGRP.

R3(config)#router eigrp 1

R3(config-router)#redistribute ospf 1 metric 10000 100 255 1 1500

R3(config-router)#exit

Originate a default route into the OSPF process from R3.

R3(config)#router ospf 1

R3(config-router)#default-information originate always

R3(config-router)#exit

Page 11: 1

3.2 SHOW IP ROUTE COMMANDS

R1#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

* - candidate default, U - per-user static route, o - ODR

P - periodic downloaded static route

Gateway of last resort is 192.168.1.134 to network 0.0.0.0

10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

D EX 10.1.1.0/29 [170/2195456] via 192.168.1.134, 03:06:55, Serial0/1

D EX 10.4.4.4/24 [170/2195456] via 192.168.1.134, 03:06:42, Serial0/1

192.168.1.0/24 is variably subnetted, 6 subnets, 2 masks

C 192.168.1.0/30 is directly connected, Loopback1

D 192.168.1.4/30 [90/2297856] via 192.168.1.134, 03:06:55, Serial0/1

D 192.168.1.96/27 [90/2297856] via 192.168.1.130, 03:06:57, Serial0/0

C 192.168.1.128/30 is directly connected, Serial0/0

C 192.168.1.132/30 is directly connected, Serial0/1

D 192.168.1.160/27 [90/2172416] via 192.168.1.130, 03:06:57, Serial0/0

[90/2172416] via 192.168.1.134, 03:06:55, Serial0/1

D* 192.168.100.0/24 [90/2297856] via 192.168.1.134, 03:06:55, Serial0/1

Page 12: 1

R2#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

* - candidate default, U - per-user static route, o - ODR

P - periodic downloaded static route

Gateway of last resort is 192.168.1.162 to network 192.168.100.0

10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

D EX 10.1.1.0/29 [170/284160] via 192.168.1.162, 03:17:15, FastEthernet0/0

D EX 10.4.4.4/32 [170/284160] via 192.168.1.162, 03:17:14, FastEthernet0/0

192.168.1.0/24 is variably subnetted, 10 subnets, 2 masks

D 192.168.1.0/30 [90/2297856] via 192.168.1.129, 03:17:42, Serial0/0

D 192.168.1.4/30 [90/156160] via 192.168.1.162, 03:17:14, FastEthernet0/0

D 192.168.1.96/27 is a summary, 03:17:47, Null0

C 192.168.1.100/30 is directly connected, Loopback101

C 192.168.1.104/30 is directly connected, Loopback105

C 192.168.1.108/30 is directly connected, Loopback109

C 192.168.1.112/30 is directly connected, Loopback113

C 192.168.1.128/30 is directly connected, Serial0/0

D 192.168.1.132/30 [90/2172416] via 192.168.1.162, 03:17:14, FastEthernet0/0

C 192.168.1.160/27 is directly connected, FastEthernet0/0

Page 13: 1

D* 192.168.100.0/24 [90/156160] via 192.168.1.162, 00:05:54, FastEthernet0/0

R3#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

* - candidate default, U - per-user static route, o - ODR

P - periodic downloaded static route

Gateway of last resort is 192.168.100.0 to network 0.0.0.0

10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

C 10.1.1.0/29 is directly connected, Serial0/1

O 10.4.4.4/32 [110/65] via 10.1.1.4, 03:11:55, Serial0/1

192.168.1.0/24 is variably subnetted, 6 subnets, 2 masks

D 192.168.1.0/30 [90/2297856] via 192.168.1.133, 03:12:09, Serial0/0

C 192.168.1.4/30 is directly connected, Loopback5

D 192.168.1.96/27 [90/156160] via 192.168.1.161, 03:11:42, FastEthernet0/0

D 192.168.1.128/30 [90/2172416] via 192.168.1.161, 03:11:42, FastEthernet0/0

C 192.168.1.132/30 is directly connected, Serial0/0

C 192.168.1.160/27 is directly connected, FastEthernet0/0

C* 192.168.100.0/24 is directly connected, Loopback192

S* 0.0.0.0/0 [1/0] via 192.168.100.0

R3#

Page 14: 1

R4#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

* - candidate default, U - per-user static route, o - ODR

P - periodic downloaded static route

Gateway of last resort is 10.1.1.3 to network 0.0.0.0

10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

C 10.1.1.0/29 is directly connected, Serial0/0

C 10.4.4.0/24 is directly connected, Loopback4

O*E2 0.0.0.0/0 [110/1] via 10.1.1.3, 03:20:51, Serial0/0

R4#

Page 15: 1

CHAPTER 4

4.1 COMPANY SUMMARY (SCENARIO 2)

Company name: International Travel Agency (ITA), with three branches in different geographical areas, London, Cape Town and San Jose

4.2 NETWORK REQUIRMENTS

* ITA relies heavily on the internet for its advertisements; therefore it has been decided to establish a primary and a backup route to the internet.

* ITA SanJose core routers must run OSPF in area 0

* London branch office in area 1 will be a totally stubby network

* Capetown branch office in Area 2 will be an Not so stubby area (NSSA)

* A third area will be a RIP subnet

* summarize all routes from each area into the core,

* Each area should have approximately 30 networks except Area 0

* Redistribute Routing information from RIP into OSPF, The RIP subnet should use default route to access the rest of the network and internet.

* Implement EZ IP for users in RIP subnet

* ITA network will be multihomed to ISP, primary link will be a T3 link connection, a backup T1 connection link will also be configured and will only be used when T3 goes down

* A firewall most be configured on sanjose3 router ASBR to allow all traffic originating inside AS 200, and deny any traffic outside 200 into the network

4.3 OBJECTIVE

Plan, design and implement the complex ITA network based on the above specified guidelines, and verify that all configurations are operational and functioning according to the guidelines.

Page 16: 1

CHAPTER 5

5.1 SETTING UP THE PHYSICAL LAYOUT OF THE NETWORK

SCENARIO 2 TOPOLOGY

Page 17: 1

SCENARIO 2 IP ADDRESS TABLE

DEVICE INTERFACE IP ADDRESS SUBNET MASK DEFAULT GATEAWAY

SANJOSE1 S0/1 172.16.3.1 255.255.255.252 NIL

S0/0 172.16.3.5 255.255.255.252 NIL

Fa1/0 172.16.3.9 255.255.255.252 NIL

FIREWALL Fa0/0 172.16.3.10 255.255.255.252 NIL

S0/0 172.16.3.13 255.255.255.252 NIL

S0/1 172.16.3.17 255.255.255.252 NIL

CAPETOWN LOOPBACK0 172.16.0.1 255.255.255.248

LOOPBACK254 172.16.0.254 255.255.255.248

Fa1/0 172.16.1.1 255.255.255.248

S0/0 172.16.3.2 255.255.255.252

LONDON S0/0 172.16.3.6 255.255.255.252

LOOPBACK2 172.16.2.1 255.255.255.248

LOOPBACK254 172.16.2.254 255.255.255.248

ISPA S0/0 172.16.3.14 255.255.255.252

S0/1 172.16.3.18 255.255.255.252

FA1/0 209.165.200.241 255.255.255.252

CHAPTER 5

Page 18: 1

ROUTER CONFIGURATIONS

Sanjose1 router configuration

hostname sanjose1

int f1/0

ip add 172.16.3.9 255.255.255.252

no shut

int s0/0

ip add 172.16.3.1 255.255.255.252

no shut

int s0/1

ip add 172.16.3.5 255.255.255.252

no shut

exit

router ospf 1

area 1 stub no-summary

area 1 range 172.16.2.0 255.255.255.0

area 2 nssa

area 2 range 172.16.0.0 255.255.255.0

network 172.16.3.9 255.255.255.252 area 0

network 172.16.3.5 0.0.0.3 area 1

network 172.16.3.1 0.0.0.3 area 2

exit

Page 19: 1

LONDON ROUTER configuration Hostname London

interface Loopback2

ip address 172.16.2.1 255.255.255.248

exit

interface Serial0/0

ip address 172.16.3.6 255.255.255.252

no shut

exit

interface loopback 254

ip address 172.16.2.254 255.255.255.248

exit

router ospf 1

area 1 stub

network 172.16.3.6 255.255.255.252 area 1

network 172.16.2.1 255.255.255.248 area 1

network 172.16.2.254 255.255.255.248 area 1

exit

Page 20: 1

CapeTown ROUTER configurations

Hostname CapeTown

Interface Loopback0

ip address 172.16.0.1 255.255.255.248

Interface Loopback254

ip address 172.16.0.254 255.255.255.248

Interface fa0/1

ip add 172.16.1.1 255.255.255.248

Interface Serial0/0

ip address 172.16.3.2 255.255.255.252

no shut

exit

router ospf 1

area 2 nssa

network 172.16.0.1 255.255.255.248 area 2

network 172.16.3.2 255.255.255.252 area 2

network 172.16.0.254 255.255.255.248 area 2

redistribute rip subnets

default-metric 5

exit

router rip

version 2

network 172.16.1.1

no auto-summary

Page 21: 1

exit

access-list 11 permit 172.16.1.0 255.255.255.0

route-map RIP-Network

match ip address 11

exit

router rip

default-information originate route-map RIP-Network

exit

interface f1/0

ip dhcp pool RIPSUBNET

network 172.16.1.0 255.255.255.0

default-router 172.16.1.1

domain-name mydomain.com

exit

Page 22: 1

Firewall Router configuration

Hostname FIREWALL

int s0/0

Description Primary link T3

ip address 172.16.3.13 255.255.255.252

no shut

exit

int s0/1

Description Secondary link T1

ip address 172.16.3.17 255.255.255.252

no shut

exit

int f1/0

Description Inside Backbone segment

ip address 172.16.3.10 255.255.255.252

no shut

exit

ip route 0.0.0.0 0.0.0.0 172.16.3.13

ip route 0.0.0.0 0.0.0.0 172.16.3.17 10

router ospf 1

network 172.16.3.10 255.255.255.252 area 0

exit

Page 23: 1

router bgp 200

network 172.16.3.13

network 172.16.3.17

neighbor 209.165.200.241 remote-as 100

no auto-summary

exit

Router ospf 1

Default-information originate always

Exit

Ip access-list extended OUTBOUNDFILTERS

Permit tcp 172.16.0.0 0.0.255.255 any

Exit

Ip access-list extended INBOUNDTRAFFIC

Permit tcp any 172.16.0.0 0.0.255.255 established

Exit

Int S0/0

Ip access-group OUTBOUNDFILTERS out

Ip access-group INBOUNDFILTERS in

Exit

Int s0/1

Ip access-group OUTBOUNDFILTERS out

Ip access-group INBOUNDFILTERS in

Exit

Page 24: 1

ISPA ROUTER CONFIGURATION

host ISPA

int fa1/0

description internet

ip add 209.165.200.241 255.255.255.252

exit

int s0/0

ip add 172.16.3.14 255.255.255.252

no shut

exit

int s0/1

ip add 172.16.3.18 255.255.255.252

no shut

exit

ip route 0.0.0.0 0.0.0.0 fa1/0

router bgp 100

net 172.16.3.14

net 172.16.3.18

net 209.165.200.241

neighbor 172.16.3.10 remote-as 200

no auto-summary

exit

interface s0/0

ip nat inside

exit

Page 25: 1

interface s0/1

ip nat inside

exit

interface F1/0

ip nat outside

exit

access-list 100 permit ip 172.16.0.0 0.0.255.255 any

route-map T3link permit 10

match ip address 100

match interface S0/0

exit

route-map T1link permit 10

match ip address 100

match interface S0/1

exit

ip nat inside source route-map T3link interface F1/0 overload

ip nat inside source route-map T1link interface F1/0 overload

ip route 0.0.0.0 0.0.0.0 F1/0


Recommended